Download AWS Certified CloudOps Engineer-Associate.SOA-C03.ExamTopics.2026-09-25.194q.tqb

Vendor: Amazon
Exam Code: SOA-C03
Exam Name: AWS Certified CloudOps Engineer-Associate
Date: Sep 25, 2026
File Size: 1 MB

How to open TQB files?

Files with TQB (Taurus Question Bank) extension can be opened by Taurus Exam Studio.

Demo Questions

Question 1
A company runs a non-production application on an Amazon EC2 instance. The application logs all error messages to a log file on the local file system. All entries that are written to the log file start with the word "error."
A CloudOps engineer must implement a solution that gives the company the ability to search for all occurrences of the error during the previous year.
Which solution will meet this requirement?
  1. Install the Amazon CloudWatch agent on the EC2 instance. Configure the agent to send logs to an Amazon CloudWatch Logs log group. Create a metric filter on the log group for all messages that include the word "error."
  2. Install the Amazon CloudWatch agent on the EC2 instance. Configure the agent to send an Amazon SNS message to an Amazon CloudWatch Logs log group. Create a metric filter on the log group for all messages that include the word "error."
  3. Configure the log file to post all messages to an Amazon SQS queue. Create an AWS Lambda function. Configure the Lambda function to determine whether the messages include the word "error."
  4. Configure the log file to send all messages to an Amazon S3 bucket. Create an event notification on the S3 bucket to publish the contents of the messages to an Amazon SQS queue.
Correct answer: A
Question 2
A company has a large on-premises tape backup solution. The company has started to use AWS Storage Gateway. The company created a Tape Gateway to replace the existing on-premises hardware. The company's backup engineer noticed that some of the backup jobs that were supposed to write to AWS failed to run because of a "Not Enough Space" error.
The company does not want these failures to happen again. The company also wants to consistently have enough tape available on AWS.
What is the MOST operationally efficient way for a CloudOps engineer to meet these requirements?
  1. Create an AWS Lambda function that runs on an hourly basis and checks how many tapes have available space. If the available tapes are below a certain threshold, provision more.
  2. Install the Amazon CloudWatch agent on the on-premises system. Push the log files to a CloudWatch log group. Create an AWS Lambda function that creates more tapes when the "Not Enough Space" error appears. Create a metric filter and a metric alarm that launches the Lambda function.
  3. Create an additional Tape Gateway with its own set of tapes. Configure Amazon SNS to send a notification to the backup engineer if the tapes that are associated with the primary Tape Gateway do not have available space.
  4. Configure tape auto-create on the Tape Gateway. In the auto-create settings, configure a minimum number of tapes, an appropriate barcode prefix, and a tape pool.
Correct answer: D
Question 3
A CloudOps engineer manages the security of accounts in an organization in AWS Organizations. The CloudOps engineer must implement a solution that applies a base configuration to all accounts when the accounts join the organization.
Which solution will meet this requirement with the LEAST operational overhead?
  1. Create the configuration in an AWS CloudFormation template. Deploy the template to all accounts in the organization by using StackSets automatic deployments.
  2. Turn on AWS Config in the organization's management account. Use multi-account, multi-Region data aggregation. Review results on the Aggregated Resources page.
  3. Create an AWS Lambda function in the organization's management account to configure resources. Configure the Lambda function with cross-account access. Run the function when a new account is detected.
  4. Create the configuration in an AWS CloudFormation template. Deploy the template to all accounts in the organization by using an AWS Lambda function that runs when a new account is detected.
Correct answer: A
Question 4
A company hosts an application on AWS that uses a 5 TB Amazon RDS for MySQL database. The company performs frequent micro updates that cannot be interrupted. Sometimes structural changes to the database cause issues for the application. When an issue occurs, the company immediately receives a notification through automated monitoring.
The company wants to undo the problematic database changes as soon as possible. The company wants to transition from RDS for MySQL to an Amazon Aurora MySQL-Compatible Edition cluster.
Which solution will meet these requirements?
  1. Create a DB cluster snapshot immediately before the update begins. If the update fails, restore the DB snapshot and modify the application to use the new DB cluster endpoint.
  2. Create a database record in an Amazon Route 53 private zone that points to the cluster endpoint. Create a DB cluster snapshot immediately before the update begins. If the update fails, restore the DB snapshot and modify DNS accordingly.
  3. Activate the backtrack feature in the Aurora cluster during the initial creation or restoration of the Aurora cluster from the RDS for MySQL database. Use backtrack to roll back the database to the point in time right before the update began.
  4. Create an RDS Proxy in front of the Aurora cluster. If the update fails, restore the DB snapshot and modify the RDS Proxy to use the new DB cluster endpoint.
Correct answer: C
Question 5
A company hosts its website on Amazon EC2 instances in the us-east-1 Region. The company is preparing to extend its website into the eu-central-1 Region, but the database must remain only in us-east-1. After deployment, the EC2 instances in eu-central-1 are unable to connect to the database in us-east-1.
What is the MOST operationally efficient solution that will resolve this connectivity issue?
  1. Create a VPC peering connection between the two Regions. Add the private IP address range of the instances to the inbound rule of the database security group.
  2. Create a VPC peering connection between the two Regions. Add the security group of the instances in eu-central-1 to the outbound rule of the database security group.
  3. Create a VPN connection between the two Regions. Add the private IP address range of the instances to the outbound rule of the database security group.
  4. Create a VPN connection between the two Regions. Add the security group of the instances in eu-central-1 to the inbound rule of the database security group.
Correct answer: A
Question 6
A company uses AWS Organizations to manage its AWS accounts. The company is implementing a CostCenter tag for business units to track costs and prevent noncompliant actions.
The company needs to prevent users from launching Amazon EC2 instances with a CostCenter tag unless the tag has specified values.
Which solution will meet this requirement with the LEAST administrative effort?
  1. Create a service control policy (SCP) for the CostCenter tag in Organizations. Define the specified values in the policy. Attach the policy to all the company's organizational units (OUs).
  2. Configure inventory collection for the EC2 instances in AWS Systems Manager Inventory. Attach the CostCenter tag to the managed instances.
  3. Create an Amazon Machine Image (AMI) for each of the company's business units. Include a user data script that tags instances when they are launched.
  4. Create an Amazon EventBridge rule that invokes an AWS Lambda function when a user launches an EC2 instance. Configure the Lambda function to apply the appropriate CostCenter tag for each user's IAM role or to terminate the instance if the tag lacks the specified values.
Correct answer: A
Question 7
A CloudOps engineer needs to implement a backup strategy for Amazon EC2 resources and Amazon RDS resources. The backup strategy must meet the following retention requirements:
  • Daily backups: must be kept for 6 days
  • Weekly backups: must be kept for 4 weeks
  • Monthly backups: must be kept for 11 months
  • Yearly backups: must be kept for 7 years
Which backup strategy will meet these requirements with the LEAST administrative effort?
  1. Use Amazon Data Lifecycle Manager to create an Amazon EBS snapshot policy. Create tags on each resource that needs to be backed up. Create multiple schedules according to the requirements within the policy. Set the appropriate frequency and retention period.
  2. Use AWS Backup to create a new backup plan for each retention requirement with a backup frequency of daily, weekly, monthly, or yearly. Set the retention period to match the requirement. Create tags on each resource that needs to be backed up. Set up resource assignment by using the tags.
  3. Create an AWS Lambda function. Program the Lambda function to use native tooling to take backups of file systems in Amazon EC2 and to make copies of databases in Amazon RDS. Create an Amazon EventBridge rule to invoke the Lambda function.
  4. Use Amazon Data Lifecycle Manager to create an Amazon EBS snapshot policy. Create tags on each resource that needs to be backed up. Set up resource assignment by using the tags. Create multiple schedules according to the requirements within the policy. Set the appropriate frequency and retention period. In Amazon RDS, activate automated backups on the required DB instances.
Correct answer: B
Question 8
An ecommerce company runs a microservices application on Amazon ECS. Customers sometimes experience high latency when the customers attempt to complete a purchase through the application.
A CloudOps engineer needs a solution to track individual transactions across multiple services to identify where latency is occurring. The solution must require minimal code changes and must provide a visual representation of service dependencies.
Which solution will meet these requirements?
  1. Set up the AWS X-Ray daemon as a sidecar container. Instrument the application code by using the X-Ray SDK. Use the service map to visualize request flows to identify latency.
  2. Configure an Amazon CloudWatch agent on ECS containers as a sidecar container. Create custom metrics for each service. Set up CloudWatch dashboards to monitor response times.
  3. Use Amazon VPC Flow Logs to collect logs for microservices that run on the ECS container. Monitor network traffic, and use the service map to identify latency between microservices.
  4. Use Amazon CloudWatch Container Insights as a sidecar container to collect container metrics. Monitor response times, and visualize request flows to identify latency.
Correct answer: A
Question 9
A company has an Amazon S3 bucket where users upload feedback items. The company also has an Amazon API Gateway REST API that processes feedback notifications.
The company needs a solution that automatically calls the API Gateway REST API when new feedback items are uploaded to the S3 bucket.
Which solution will meet these requirements?
  1. Configure an event notification for the S3 bucket with API Gateway as the destination. Use the s3:ObjectAcl:Put event.
  2. Configure an event notification for the S3 bucket with Amazon EventBridge as the destination. Configure an EventBridge rule that monitors for the S3 event and calls the API Gateway REST API.
  3. Create a Lambda@Edge function that calls the API Gateway REST API when a new feedback item is uploaded. Configure an event notification for the S3 bucket with the Lambda@Edge function as the destination.
  4. Create an Amazon SQS queue. Configure an event notification for the S3 bucket with the SQS queue as the destination. Configure Amazon SQS to push new events to the API Gateway REST API.
Correct answer: B
Question 10
A company's application consists of AWS Lambda functions that access an Amazon RDS instance. Occasionally, the application load creates an unexpectedly high volume of database connections. The high volume of connections causes the RDS instance to rapidly exhaust its compute resources, leading to downtime for users.
A CloudOps Administrator must make the application more resilient to increased load without making modifications to the application code.
Which solution will meet these requirements?
  1. Use Amazon ElastiCache (Redis OSS) with Amazon RDS. Point the application to ElastiCache (Redis OSS).
  2. Use Amazon RDS Proxy with Amazon RDS. Point the application to Amazon RDS Proxy.
  3. Create a Lambda function with that invokes an Amazon EventBridge rule to scale the RDS instance based on usage.
  4. Use Amazon ElastiCache (Memcached) with Amazon RDS. Point the application to ElastiCache (Memcached).
Correct answer: B
HOW TO OPEN VCE FILES

Use VCE Exam Simulator to open VCE files
Avanaset

HOW TO OPEN VCEX FILES

Use ProfExam Simulator to open VCEX files
ProfExam Screen

ProfExam
ProfExam at a 20% markdown

You have the opportunity to purchase ProfExam at a 20% reduced price

Get Now!